Driftgate Xalt and Xsplit

Post Reply
Seaweed
Posts: 2
Joined: Tue Aug 29, 2017 9:27 pm
Anti Spam measure: No
AntiSpam Text: Westerly

Driftgate Xalt and Xsplit

Post by Seaweed »

We bought our Konsort over a year ago, with most, but not all operating manuals. I've tried to get them for the alternator charging system, but no luck. The engine is a Beta 30, with a modified alternator. (The ever helpful team at Beta today confirmed that they had modified the alternator for a charge boosting system and even sent me a photo of the alternator with the extra wire added! Superb service.)

The charging system is by the Driftgate Company, of St Neotts, now, I believe, no longer trading. There is an "Xalt Buccaneer" Alternator Boost Controller and an "Xsplit" Electronic Charge Splitter feeding the engine and house batteries. They were not fitted by Beta, but by the yard that replaced the engine in about 2011/2012.

At the weekend, the field wire to the alternator, connection D1 broke and the alarm buzzer and light flashed as would be expected. I repaired it and all seems well, but the LED on the Xalt seems to be misbehaving, flashing amber, then green for a few minutes, then red, then back to amber. To be frank, it might always have done this - it is tucked below the quarterberth next to the batteries and is usually out of sight.

So: can anyone point me at a set of manuals or drawings that would explain what's going on? It's not urgent, but I'd like to be sure I haven't got a problem developing.
Jolly Roger
Posts: 1005
Joined: Mon Sep 02, 2013 1:08 pm
Anti Spam measure: No
AntiSpam Text: Westerly
Location: Kent, UK

Re: Driftgate Xalt and Xsplit

Post by Jolly Roger »

Seaweed

Welcome to the WOA Forum.

Sorry I cannot help with this alternator booster. You may find a quicker answer on the ybw.com forum, as there are some very knowledgeable electrical boffins there and are more likely to find someone with the same unit who can answer your question. These old threads might help:
http://www.ybw.com/forums/showthread.ph ... or-booster
http://www.ybw.com/forums/showthread.ph ... structions
http://forums.ybw.com/forums/showthread ... w-approach

I see that Philip Stevens (of the WOA forum) made some comments, so I expect he should read this in the near future and may be able to help.
Roger
Concerto Fulmar FR38
Photos at http://s1294.photobucket.com/user/Conce ... 2/library/
Seaweed
Posts: 2
Joined: Tue Aug 29, 2017 9:27 pm
Anti Spam measure: No
AntiSpam Text: Westerly

Re: Driftgate Xalt and Xsplit

Post by Seaweed »

Many thanks. I think my problem is that I don't even know how the charger works in principle, so flashing LED's don't tell me much. I've had no problems with the system and the batteries are always well charged. One point to note is that the house batteries (2x110Ah) are normally at 0.3 volts less than the engine battery (110Ah). so, typically 12.9V and 12.6V on arrival at the boat. I assume the Xalt bases its operation on one of these voltages and then sends the output to the Xsplit to divide between the two banks.

I'll await further advice or a pointer to manuals or diagram. Much appreciated. :)
User avatar
philipstevens
Posts: 1024
Joined: Thu Feb 16, 2006 5:10 pm
Anti Spam measure: Yes
AntiSpam Text: Westerly
Location: Home Nr. Saint Ives, Cornwall.

Re: Driftgate Xalt and Xsplit

Post by philipstevens »

regards,
Philip.
Moderator and Admin.

Previous owner of Konsort Duo, Oyster, KD22

Join the WOA - only £15 per year (UK) http://www.westerly-owners.co.uk/ab_join.php

http://www.marketmechina.com/ & http://www.celticwebdesign.net
Post Reply