Page 1 of 1

MD2B engine mounts in 1971 Centaur

Posted: Fri Jun 27, 2014 12:27 pm
by Katouf
Have had an argument with a mooring rope and lost! :(
Propellor took hold of 25mm polypropylene and wound itself backwards pulling the engine about 35mm aft, shearing all 4 mounts and stopping the engine dead when the ring gear on the flywheel hit the angle iron beds.
Would anyone know what size mountings were used in November 1971? Would prefer a like for like replacement as I do not want to mess about with alterations to the position of the beds itself.

Alan
Katouf CR505

Re: MD2B engine mounts in 1971 Centaur

Posted: Fri Jun 27, 2014 6:36 pm
by smudger
Hi,got any pics?

Re: MD2B engine mounts in 1971 Centaur

Posted: Thu Jul 24, 2014 8:56 am
by paulcd
Hi Replaced mine 2 seasons ago when i took the engine out, bought them from RK Marine in Bursledon, mine is a 1973 Centaur.

Re: MD2B engine mounts in 1971 Centaur

Posted: Fri Aug 22, 2014 11:56 am
by Katouf
Further to original post in June, the approved engineer recommended by the insurance broker has found that the gearbox coupling, the shaft and keyway have had some play in them which seemed to show that the engine had not been properly aligned for a long time. There was no sign of any shims and the new mountings (at present unseen as supplied by the engineer but are the same general size as the original removed to get the correct spec) can't be fitted until the shaft has been replaced. Am taking the opportunity to replace the cutless bearing as the old one was worn. I offered to pay for that myself rather than inflate the claim still further!

2 month's sailing lost so far - might be ready next week with any luck. Fingers crossed.

Alan
Katouf CR505