autohelm/tillerpilot repair

Post Reply
giles watling
Posts:9
Joined:Fri May 18, 2012 11:11 am
Anti Spam measure:Yes
AntiSpam Text:champers
autohelm/tillerpilot repair

Post by giles watling » Tue Sep 27, 2016 7:04 am

Hi All

Looking for help/advice please. I've been running up and down the East Coast with an old Mini Seacourse tillerpilot which has been an invaluable aid. This year Mavis (as she is known aboard my Centaur) decided to go off on a route of her own causing much banging about of the rigging. I have taken her apart and tried to find the cause with no success. It seems she will work for a while, but then have a kniption fit and extend or retract to the end of the control arm - then jam... She has been due for retirement for some time so although I will miss her simplicity and ease of operation the time has come.

So now I have been given a Simrad TP 10 which also doesn't work (looking good this). The Simrad fires up but doesn't seem to respond to being moved in a lateral plane. I can make the control arm move in 10 degree increments by pushing the buttons so it seems the motor and drive generally is good, but there is no correcting response when the entire unit is moved. The circuit board seems OK - nothing burned out and the compass seems OK. Has anyone had one of these things apart at all? Is there an obvious fix I am missing?

Any help gratefully received.

Cheers

Giles - Centaur 'Drift', Walton Backwaters

Vegable
Posts:305
Joined:Sat Apr 28, 2007 3:27 pm
Anti Spam measure:No
AntiSpam Text:Westerly
Location:Abersoch; N.Wales, Boat back in Arisaig.

Re: autohelm/tillerpilot repair

Post by Vegable » Tue Oct 04, 2016 8:27 am

As nobody else has replied, and this is pure guesswork on my part, it sounds to me as though the compass is playing up as that seems to be common to both systems. Never had one apart and have never fiddled with them either so that's the limit of my help I'm afraid.
Mike
"There is nothing worse than running ashore, unless you are uncertain as to which continent that shore belongs"

NeilRaven
Posts:2
Joined:Mon May 08, 2017 4:06 pm
Anti Spam measure:No
AntiSpam Text:Westerly

Re: autohelm/tillerpilot repair

Post by NeilRaven » Mon May 22, 2017 4:11 pm

I inherited an Autohelm Tillerpilot with my current Fulmar that did not show too many signs of working. On taking it apart I found it was somewhat encrusted with salt and the circuit board was the same. I took a moist toothbrush to all the solder joints on the circuit board to remove the salt and hey presto, it worked. Hopefully you may be as lucky as I.

Post Reply